use strict;
my $str = 'Diet Pepsi Can 76.34 1 0.00 76.34 Subtotal 76.34 Total Amount (Before Tax) 76.34 Tax Details —— -------——---------- VAT @ 25% 19 09 Tax Amount 19.09 Service Tax Details-------------------- Service Tax (§j 6.00% 4 58 Service Tax Amount 4.58 Gross Amount 100.01 Rounded 0.01 Bill Amount 100.00 Payments -------—--------------------- Cash 100.00 Ragd. Off. : F2/7, Okhla Phase-1, New Delhi-110020 Email ID : dasmpl@dll-rJcorp.com Website : www.dll-rjcorp.com Tel No. : Oil -41706720 Fax No. : 011 -26812665 Thank You for choosing Pizza Hut See us online at www.plzzahut.co.in Have A Nice Day Total Payment 100.00\'
^\\s*[A-Za-z]+(?:\\s+[A-Za-z]+)*\\s*$';
my $regex = qr/([a-zA-Z[:punct:]]+(?:\s+[A-Za-z[:punct:]]+)*)([ ]+[0-9]+\.[0-9]{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}