$re = '/^5((\d)\2{3})((\d)\4{3})$/m';
$str = '511112222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);