$re = '/(?<=^|\s)[A-Z]{3,6}(?=\s|$)/m';
$str = 'ABC (ABC c GFSDG ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);