package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^.+((\?|&)utm_source=).+$`)
var str = `http://www.glomdalen.no?utm_source=facebook
http://www.glomdalen.no&utm_source=facebook`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}