import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SetVariable>[\\w\\n\\t\\s=\\\":<>\\/\\-_.]*?stringValue=\\\"([\\w\\n\\t\\s=\\\":<>\\/\\-_.]*?)\\\"\\/>[\\w\\n\\t\\s=\\\":<>\\/\\-_.]*?(?!booleanValue)[\\w\\n\\t\\s=\\\":<>\\/\\-_.]*?VariableToSet stringValue=\\\"serviceName\\\"[\\w\\n\\t\\s=\\\":<>\\/\\-_.]*?L7p:SetVariable>";
final String string = " <L7p:VariableToSet stringValue=\"dateTo\"/>\n"
+ " </L7p:SetVariable>\n"
+ " <L7p:SetVariable>\n"
+ " <L7p:Base64Expression stringValue=\"UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ\"/>\n"
+ " <L7p:Enabled booleanValue=\"false\"/>\n"
+ " <L7p:VariableToSet stringValue=\"serviceName\"/>\n"
+ " </L7p:SetVariable>\n"
+ " <L7p:Include>\n"
+ " <L7p:Enabl\n\n"
+ " <L7p:Base64Expression stringValue=\"Q1RUUklCVVQ=\"/>\n"
+ " <L7p:VariableToSet stringValue=\"SpCodeTablesSP.inputdata.TableCodeId\"/>\n"
+ " </L7p:SetVariable>\n"
+ " <L7p:SetVariable>\n"
+ " <L7p:Base64Expression stringValue=\"U3BDb2RlVGFibGVzU1A=\"/>\n"
+ " <L7p:VariableToSet stringValue=\"serviceName\"/>\n"
+ " </L7p:SetVariable>\n"
+ " <L7p:Include>\n"
+ " <L7p:Pol";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}