using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^\-)\D";
string substitution = @"";
string input = @"-98+-098.ojhfiour0989e87";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}