$re = '/^\d+(?:-\d+)?\.? /m';
$str = '1-09. But Not for Me.mp3
1-11. Summertime.mp3
1-12. My Funny Valentine.mp3
13. Indiana (Back Home Again in Indiana).mp3
2-02 I Love You.mp3
2-05 You\'d Be So Nice To Come Home To.mp3
2-11. A Foggy Day.mp3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;