$re = '/^(?\'num_externe\'.*?)\x7C(?\'ins_libl\'.*?)\x7C(?\'ins_libl_complement\'.*?)\x7C(?:.*?\x7C)(?\'apt_nom\'.*?)\x7C(?\'apt_telephone\'.*?)\x7C(?:.*?\x7C){6}(?\'tsy_lib\'.*?)\x7C(?:.*?\x7C){17}(?\'apt_localisation\'.*?)\x7C(?:.*?\x7C){9}(?\'commentaire_externe\'.*)/m';
$str = '1906823505|BPA|CORENC-BPAUR0133|LR35788G|LEONETTI CATHERINE|04.76.88.14.14||INT|MG_ENS_010002|Ensemble Chauffage-Climatisation||MNT|MG116|05/06/2019 17:36:00|06/06/2019 10:36:00|4|FR|05/06/2019 16:36:00|BPA|CORENC-BPAUR0133|LR35788G|BPAURA-ENGIE LOIR|ENGIE COFELY LOIRE|0|||313|002|A1 - ESPACE 4|0|BP AUVERGNE RHONE ALPES (CORENC-BPAUR0133)|2 AVENUE DU GRESIVAUDAN||38700|CORENC|0438884619||||1906823505|merci d\'intervenir pour rétablir la clim à l\'agence
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);