package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:5[1-5][0-9]{2}|222[1-9]|22[3-9][0-9]|2[3-6][0-9]{2}|27[01][0-9]|2720)(?:[0-9]{3}){4,5}$`)
var str = `2221000000000009
2223000048400011
2223016768739313
5555555555554444
5105105105105100
22230167687393135
2223016768739313565`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}