$re = '/([0-9]+(?:[.,][0-9]+)?)=([0-9]+(?:[.,][0-9]+)?);/';
$str = '41=26; 42=27,5; 43=28;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);