re = /(?<= |<)[a-zA-Z]*(?==| )/m
str = '<button type="sasasasasa" abcd="dsqdsq" efgh="sasasa">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end