package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d(?:\.\d+)?)`)
var str = `4.173.7
4.0
3.9
3
1.0.0
abcd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}