$re = '/(?sm)^;\s*\r?\n(.*?)\s*(?=^;\s*\r?\n)/';
$str = ';
the color blue
;
the color green
;
the color red
;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);