$re = '/^[^.]*\.\K.+$/m';
$str = '
api.mydiomain.org.local
app.stg.mydiomain.org.local
uses.anotherdomain.uk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);