re = /monitoringLayer_amfsData\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)/
str = 'monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end