re = /cow\n(.*(?:\n(?!milk$).*)*)\nmilk/m
str = 'Their
cow
gives
more
milk
His
cow
gives
less
milk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end