# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?<e2eventduration>(.*?)</e2eventduration"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<e2currentserviceinformation>\n"
" <e2service>\n"
" <e2servicereference>1:0:19:33F5:3ED:1:C00000:0:0:0:</e2servicereference>\n"
" <e2servicename>ORF2St HD</e2servicename>\n"
" <e2providername>ORF</e2providername>\n"
" <e2videowidth>1280</e2videowidth>\n"
" <e2videoheight>720</e2videoheight>\n"
" <e2servicevideosize>1280x720</e2servicevideosize>\n"
" <e2iswidescreen>\n"
"1 </e2iswidescreen>\n"
" <e2apid>3001</e2apid>\n"
" <e2vpid>3000</e2vpid>\n"
" <e2pcrpid>3000</e2pcrpid>\n"
" <e2pmtpid>301</e2pmtpid>\n"
" <e2txtpid>3005</e2txtpid>\n"
" <e2tsid>1005</e2tsid>\n"
" <e2onid>1</e2onid>\n"
" <e2sid>13301</e2sid>\n"
" </e2service>\n"
" <e2eventlist>\n"
" <e2event>\n"
" <e2eventservicereference>1:0:19:33F5:3ED:1:C00000:0:0:0:</e2eventservicereference>\n"
" <e2eventservicename>ORF2St HD</e2eventservicename>\n"
" <e2eventprovidername>ORF</e2eventprovidername>\n"
" <e2eventid>42253</e2eventid>\n"
" <e2eventname>Daheim in Österreich</e2eventname>\n"
" <e2eventtitle>Daheim in Österreich</e2eventtitle>\n"
" <e2eventdescription></e2eventdescription>\n"
" <e2eventstart>1514392200</e2eventstart>\n"
" <e2eventduration>3600</e2eventduration>\n"
" <e2eventremaining>1034</e2eventremaining>\n"
" <e2eventcurrenttime>1514394766</e2eventcurrenttime>\n"
" <e2eventdescriptionextended></e2eventdescriptionextended>\n"
" </e2event>\n"
" <e2event>\n"
" <e2eventservicereference>1:0:19:33F5:3ED:1:C00000:0:0:0:</e2eventservicereference>\n"
" <e2eventservicename>ORF2St HD</e2eventservicename>\n"
" <e2eventprovidername>ORF</e2eventprovidername>\n"
" <e2eventid>42254</e2eventid>\n"
" <e2eventname>konkret</e2eventname>\n"
" <e2eventtitle>konkret</e2eventtitle>\n"
" <e2eventdescription></e2eventdescription>\n"
" <e2eventstart>1514395800</e2eventstart>\n"
" <e2eventduration>950</e2eventduration>\n"
" <e2eventremaining>1984</e2eventremaining>\n"
" <e2eventcurrenttime>1514394766</e2eventcurrenttime>\n"
" <e2eventdescriptionextended></e2eventdescriptionextended>\n"
" </e2event>\n"
" </e2eventlist>\n"
"</e2currentserviceinformation>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.