package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`prefix:\w+,\w+,\s*-?[0-9]{1,4}\s*,\s*-?[0-9]{1,4}\s*,\s*-?[0-9]{1,4}\s*,(?:\w+)`)
var str = `prefix:string,string,-100,100,0,string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}