$re = '/\b(?=[a-zA-Z0-9]*[0-9])[a-zA-Z0-9]*[a-zA-Z][a-zA-Z0-9]*\b/';
$str = '907525191737280e , hjjhkj789jkh 2554nagy289 2 8 2 2 7 5 2 working welcome , a dp83640 , dp83867 e2 e25
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);