// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\<li\>D.*?de\:.*?\(([\+\-]?\d*)\s*siden").unwrap();
let string = "<link rel=\"canonical\" href=\"https://nyheder.tv2.dk/samfund/2020-10-11-nyeste-coronatal-fra-danmark-og-verden-saa-mange-er-smittede-doede-og-indlagte\" />
</head>
<body>
<div class=\"tc_root\" id=\"root\">
<header class=\"tc_header tc_header--color-base-red\" data-adobe-context=\"menu\" aria-label=\"Global top\"><div class=\"tc_deck tc_deck--gapless tc_deck--full\"><div class=\"tc_header__global\"><div class=\"tc_header__skip\"><a href=\"#main\" class=\"tc_header__skip__link\">Hop til indhold</a></div><a href=\"https://tv2.dk\" class=\"tc_header__logo\" title=\"Gå til forsiden af tv2.dk\"><svg class=\"tc_icon__tv2logo\" xmlns=\"http://www.w3.org/2000/svg\" width=\"90\" height=\"40\" viewBox=\"0 0 90 40\"><title>TV 2 Logo</title><path d=\"M89.992 10.172c.3 7.647-8.03 14.59-16.056 14.59h-20.62l5.656-8.324c.44-.663 1.464-1.2 2.274-1.2H75.57c1.847 0 3.85-1.693 3.666-3.555-.155-1.495-1.364-2.144-2.657-2.16H44.55L50.205 1.2C50.66.535 51.668 0 52.478 0h26.26c5.657 0 11.014 4.135 11.254 10.172zm-51.81-1.847L43.84 0H7.93c-.797 0-1.82.536-2.274 1.2L0 9.522h35.91c.81 0 1.82-.535 2.273-1.198zM17.877 40h16.27c.796 0 1.82-.535 2.274-1.2l16-23.562h-10.3c-.797 0-1.82.537-2.275 1.2L25.763 37.164l2.33-21.926h-10.67L15.12 36.966C14.95 38.646 16.17 40 17.876 40zm61.076-1.213l5.655-8.325H50.9c-.795 0-1.818.538-2.272 1.2l-5.657 8.325H76.68c.81.013 1.833-.522 2.274-1.2z\"></path></svg></a><nav class=\"tc_header__global__nav\" aria-label=\"Global top\"><ul class=\"tc_header__global__list\"><li class=\"tc_header__global__list__item tc_header__global__list__item--menu\"><a class=\"tc_header__global__list__link\" href=\"https://tv2.dk/navigation\" data-navigation-overlay-url=\"https://navigation.services.tv2.dk/html/navigation\" role=\"button\" aria-haspopup=\"true\" aria-expanded=\"false\" aria-controls=\"navigation-overlay\"><span class=\"tc_header__global__list__text\">Menu</span><svg class=\"tc_icon__menu__open\" xmlns=\"http://www.w3.org/2000/svg\" width=\"21\" height=\"21\" viewBox=\"0 0 21 21\"><path d=\"M.7 3h19.5c.5 0 .8-.7.8-1.5S20.7 0 20.3 0H.7C.3 0 0 .7 0 1.5S.3 3 .7 3zm19.6 6H.7c-.4 0-.7.7-.7 1.5S.3 12 .7 12h19.5c.5 0 .8-.7.8-1.5S20.7 9 20.3 9zm0 9H.7c-.4 0-.7.7-.7 1.5S.3 21 .7 21h19.5c.5 0 .8-.7.8-1.5s-.3-1.5-.7-1.5z\"></path></svg><svg class=\"tc_icon__menu__close\" xmlns=\"http://www.w3.org/2000/svg\" width=\"21\" height=\"21\" viewBox=\"0 0 21 21\"><path d=\"M11.5 10.5l9.3-9.2c.3-.3.3-.7 0-1-.3-.3-.7-.3-1 0l-9.3 9.2L1.3.2C1 0 .5 0 .2.2 0 .5 0 1 .2 1.3l9.2 9.2-9.2 9.2c-.3.3-.3.7 0 1 .2.3.4.3.6.3s.4 0 .5-.2l9.2-9.2 9.2 9.2c.2.2.4.2.5.2.2 0 .4 0 .5-.2.3-.3.3-.7 0-1l-9.2-9.3z\"></path></svg></a></li><li class=\"tc_header__global__list__item tc_header__global__list__item--login\"><a href=\"https://mit.tv2.dk\" class=\"tc_header__global__list__link\" aria-label=\"TV 2 Login\"><svg class=\"tc_icon__login\" xmlns=\"http://www.w3.org/2000/svg\" width=\"21\" height=\"21\" viewBox=\"0 0 21 21\"><path d=\"M15.82 9.82c.68-1.03 1.02-2.2 1.02-3.47C16.85 2.83 14.02 0 10.5 0S4.15 2.83 4.15 6.35c0 1.27.39 2.49 1.02 3.47C2.1 11.67 0 15.04 0 18.9v.39C0 20.22.78 21 1.71 21h17.58c.93 0 1.71-.78 1.71-1.71v-.39c0-3.86-2.1-7.23-5.18-9.08zM10.5 1.47c2.69 0 4.88 2.2 4.88 4.88s-2.2 4.88-4.88 4.88-4.88-2.19-4.88-4.88 2.19-4.88 4.88-4.88zm9.04 17.82c0 .15-.1.24-.24.24H1.71c-.15 0-.24-.1-.24-.24v-.39c0-3.42 1.9-6.4 4.69-7.91 1.12 1.08 2.69 1.71 4.35 1.71s3.22-.68 4.35-1.71c2.78 1.56 4.69 4.49 4.69 7.91v.39z\"></path></svg></a></li><li class=\"tc_header__global__list__item tc_header__global__list__item--search\"><a href=\"https://search.tv2.dk/\" class=\"tc_header__global__list__link\" aria-label=\"Søg på tv2.dk\"><svg class=\"tc_icon__search\" xmlns=\"http://www.w3.org/2000/svg\" width=\"21\" height=\"21\" viewBox=\"0 0 21 21\"><path d=\"M20.8 19.8l-6.5-6.5c1.2-1.4 1.9-3.2 1.9-5.2C16.1 3.6 12.5 0 8.1 0 3.6 0 0 3.6 0 8.1c0 4.4 3.6 8.1 8.1 8.1 2 0 3.8-.7 5.2-1.9l6.5 6.5c.1.1.3.2.5.2s.4-.1.5-.2c.3-.3.3-.8 0-1M1.5 8.1c0-3.6 3-6.6 6.6-6.6s6.6 3 6.6 6.6c0 1.8-.7 3.5-1.9 4.7-1.2 1.2-2.8 1.9-4.7 1.9-3.7 0-6.6-3-6.6-6.6\"></path></svg></a></li><li class=\"tc_header__global__list__item tc_header__global__list__item--play\"><a href=\"https://play.tv2.dk\" class=\"tc_header__global__list__link\" aria-label=\"TV 2 PLAY\"><svg class=\"tc_icon__play\" xmlns=\"http://www.w3.org/2000/svg\" width=\"109\" height=\"14\" viewBox=\"0 0 109 14\"><path d=\"M4.3 3.6H0V.3h12.3v3.3H8.1V14H4.3V3.6zM14.5.3h4.1l2.8 9.3L24.2.3h4.1L23.5 14h-4.2L14.5.3zM35.9 12.5c-.2-6.2 7-6.2 7-8.2 0-.6-.4-1.2-1.8-1.2-1.2 0-2.5.6-3.6 1.4L35.7 2c1.6-1.2 3.7-2 5.9-2 3.3 0 5.1 2 5.1 4 0 4.7-7 4.3-7 7.1H46V14H36l-.1-1.5zM55.7.3h6c4.2 0 5.7 2.2 5.7 4.5S66 9.4 61.8 9.4h-2.2V14h-3.8V.3zm5.9 6.2c1.2 0 1.9-.6 1.9-1.6 0-1.1-.7-1.6-1.9-1.6h-2.2v3.3l2.2-.1zM70 .3h3.8v10.5H80V14H70V.3zM87.3.3h4.2L96.3 14h-4.1l-.6-2h-4.4l-.6 2h-4.1L87.3.3zm.7 8.8h2.8l-1.4-4.5L88 9.1zM100.1 8.5L95 .3h4.3l2.7 4.5 2.7-4.5h4.3l-5.1 8.3V14H100V8.5z\"></path></svg></a></li></ul></nav></div><nav class=\"tc_header__local\" aria-label=\"Sektionsmenu\"><div class=\"tc_header__local__inner\"><div class=\"tc_heading tc_heading--3 tc_heading--slant tc_heading--uppercase tc_heading--slash-true\"><a href=\"https://nyheder.tv2.dk/\" class=\"tc_header__local__link\" aria-label=\"Nyheder\">Nyheder</a></div><ul class=\"tc_header__list__local\"><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/seneste\" class=\"tc_header__list__local__link\">Seneste</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/coronavirus\" class=\"tc_header__list__local__link tc_header__list__local__link--active\">Coronavirus</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/politik\" class=\"tc_header__list__local__link\">Politik</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/krimi\" class=\"tc_header__list__local__link\">Krimi</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/samfund\" class=\"tc_header__list__local__link\">Samfund</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/udland\" class=\"tc_header__list__local__link\">Udland</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/business\" class=\"tc_header__list__local__link\">Business</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/penge\" class=\"tc_header__list__local__link\">Penge</a></li><li class=\"tc_header__list__local__item\"><a href=\"https://nyheder.tv2.dk/tech\" class=\"tc_header__list__local__link\">Tech</a></li></ul></div></nav></div><div class=\"tc_header__overlay\" id=\"navigation-overlay\"></div></header><div data-ad=\"topbanner-1\" class=\"tc_ad tc_ad--topbanner\" data-sizes-medium=\"1x1,930x180,fluid\" data-sizes=\"1x1,320x160,fluid\" data-exclude-decider=\"1\" aria-hidden=\"true\"></div><div class=\"tc_ad tc_ad--dd\"></div><div data-ad=\"interscroll-1\" data-ad-ignore=\"true\" class=\"tc_ad tc_ad--interscroll\" aria-hidden=\"true\"></div><div data-ad=\"skyscraperleft-1\" class=\"tc_ad tc_ad--skyscraperleft tc_ad--sticky\" data-sizes-skyscrapers=\"160x600,160x601,fluid\" data-sizes=\"none\" data-exclude-on=\"dd,interscroll\" aria-hidden=\"true\"></div><div data-ad=\"skyscraperright-1\" class=\"tc_ad tc_ad--skyscraperright tc_ad--sticky\" data-sizes-skyscrapers=\"160x600,160x602,fluid\" data-sizes=\"none\" data-exclude-on=\"dd,interscroll\" aria-hidden=\"true\"></div><main id=\"main\"><article class=\"tc_deck tc_article__wrapper\" aria-label=\"Artikel\"><div class=\"tc_deck tc_deck--gapless tc_deck--colxl\"><div class=\"tc_grid tc_grid--gutter\"><header class=\"tc_page__header\"><a href=\"https://nyheder.tv2.dk/coronavirus\" class=\"tc_label tc_label--color-base-red\" aria-label=\"Sektion\">Coronavirus</a><h1 class=\"tc_heading tc_heading--1 tc_heading--weight-700\">Nyeste coronatal fra Danmark og verden: Så mange er smittede, døde og indlagte</h1><div class=\"tc_page__header__meta\"><div class=\"tc_page__header__timestamp\"><time class=\"tc_timestamp\" dateTime=\"2020-10-11T12:09:15.000Z\" aria-label=\"Publiceringstidspunkt\"> <!-- -->11. okt. 2020, 14:09</time><time class=\"tc_timestamp tc_timestamp--updated\" dateTime=\"2021-01-13T18:34:48.000Z\"><abbr title=\"Opdateret\" aria-label=\"Opdateret\">Opd.</abbr> <!-- -->13. jan. 2021, 19:34</time></div><div class=\"tc_page__header__social\"><div class=\"tc_socialbuttons tc_socialbuttons--line\"><ul class=\"tc_socialbuttons__list\" aria-label=\"Deling på sociale medier\"><li class=\"tc_socialbuttons__item\"><a href=\"https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnyheder.tv2.dk%2Fsamfund%2F2020-10-11-nyeste-coronatal-fra-danmark-og-verden-saa-mange-er-smittede-doede-og-indlagte&t=Nyeste%20coronatal%20fra%20Danmark%20og%20verden%3A%20S%C3%A5%20mange%20er%20smittede%2C%20d%C3%B8de%20og%20indlagte\" class=\"tc_socialbuttons__action\"><svg xmlns=\"http://www.w3.org/2000/svg\" width=\"9.3\" height=\"20\" viewBox=\"0 0 9.3 20\"><path d=\"M9.3 6.5H6.1V4.4c0-.8.5-1 .9-1h2.2V0h-3C2.8 0 2 2.6 2 4.2v2.3H0V10h2v10h4.2V10H9l.3-3.5\"></path></svg><span class=\"tc_socialbuttons__action__text\">Del på Facebook</span></a></li><li class=\"tc_socialbuttons__item\"><a href=\"https://twitter.com/intent/tweet?url=https%3A%2F%2Fnyheder.tv2.dk%2Fsamfund%2F2020-10-11-nyeste-coronatal-fra-danmark-og-verden-saa-mange-er-smittede-doede-og-indlagte&text=Nyeste%20coronatal%20fra%20Danmark%20og%20verden%3A%20S%C3%A5%20mange%20er%20smittede%2C%20d%C3%B8de%20og%20indlagte\" class=\"tc_socialbuttons__action\"><svg xmlns=\"http://www.w3.org/2000/svg\" width=\"22\" height=\"17.8\" viewBox=\"0 0 22 17.8\"><path d=\"M1.5.8S5 5.4 10.8 5.5c0 0-1.1-4.1 3.4-5.4 2.3-.7 4.2 1.3 4.2 1.3s1.2-.1 3-1.1c-.2 1.1-2 2.5-2 2.5s1.9-.2 2.6-.7c-.5.8-2.1 2.3-2.2 2.4-.1.1.3 4.8-3 8.8-3.1 4-10.8 6.5-16.8 2.5 3.5.5 6.7-1.8 6.6-1.8-.2 0-2.9 0-4.2-3.2.1 0 1.4.2 2-.1.5-.1-3.1 0-3.5-4.4 1.3.6 2 .5 2 .5s-3.4-2-1.4-6\"></path></svg><span class=\"tc_socialbuttons__action__text\">Del på Twitter</span></a></li><li class=\"tc_socialbuttons__item\"><a href=\"mailto:?subject=Nyeste%20coronatal%20fra%20Danmark%20og%20verden%3A%20S%C3%A5%20mange%20er%20smittede%2C%20d%C3%B8de%20og%20indlagte&body=https%3A%2F%2Fnyheder.tv2.dk%2Fsamfund%2F2020-10-11-nyeste-coronatal-fra-danmark-og-verden-saa-mange-er-smittede-doede-og-indlagte\" class=\"tc_socialbuttons__action\" rel=\"noopener noreferrer\"><svg xmlns=\"http://www.w3.org/2000/svg\" width=\"20\" height=\"12\" viewBox=\"0 0 20 12\"><path d=\"M18.5 0h-17L10 8.5\"></path><path d=\"M10.6 10c-.1.1-.1.1 0 0-.2.2-.4.3-.6.3-.2 0-.4-.1-.5-.2L.1.7C0 .9 0 1 0 1.2v9.6c0 .7.5 1.2 1.1 1.2h17.8c.6 0 1.1-.5 1.1-1.2V1.2c0-.2 0-.3-.1-.5L10.6 10z\"></path></svg><span class=\"tc_socialbuttons__action__text\">Del på e-mail</span></a></li></ul></div></div></div></header></div></div><div class=\"tc_deck tc_deck--gapless tc_deck--colxl\"><div class=\"tc_grid tc_grid--gutter\" data-grid-lg=\"row_2-1\"><div class=\"tc_grid\"><div class=\"tc_byline\"><span class=\"tc_byline__prefix\">af </span><a href=\"https://shared.tv2.dk/profil/yan-kovyakh\" class=\"tc_byline__author\" aria-label=\"Forfatter\"><span class=\"tc_byline__author__info\"><strong class=\"tc_byline__author__name\">Yan Kovyakh</strong></span>, </a><a href=\"https://nyheder.tv2.dk/profil/lasse-kalhauge\" class=\"tc_byline__author\" aria-label=\"Forfatter\"><span class=\"tc_byline__author__info\"><strong class=\"tc_byline__author__name\">Lasse Kalhauge</strong></span>, </a><a href=\"https://nyheder.tv2.dk/profil/said-nuh\" class=\"tc_byline__author\" aria-label=\"Forfatter\"><span class=\"tc_byline__author__info\"><strong class=\"tc_byline__author__name\">Said Nuh</strong></span>, </a><a href=\"https://nyheder.tv2.dk/profil/nikolaj-albrectsen\" class=\"tc_byline__author\" aria-label=\"Forfatter\"><span class=\"tc_byline__author__info\"><strong class=\"tc_byline__author__name\">Nikolaj Albrectsen</strong></span> & </a><a href=\"https://nyheder.tv2.dk/profil/magnus-bjerg\" class=\"tc_byline__author\" aria-label=\"Forfatter\"><span class=\"tc_byline__author__info\"><strong class=\"tc_byline__author__name\">Magnus Bjerg</strong></span></a><span class=\"tc_byline__author__text\"><span> & Esben Christensen</span></span></div><div class=\"tc_page__body\" data-adobe-context=\"article-body\"><p class=\"tc_page__body__standfirst\"><strong>Få her overblikket over, hvor mange der er indlagt og smittet efter udbruddet af covid-19, og hvordan smitten har spredt sig.</strong></p><div style=\"display:none\"><!-- \"Debug info:\\n StructuredContent can not render the blocks, because they contain unsupported types: \" --></div><div class=\"tc_richcontent\"><ul>
<li>Smittede: 185.159 (+1358 siden i går)</li>
<li>Døde: 1660 (+37 siden i går)</li>
<li>Indlagt: 859 (-58 siden i går)</li>
<li>På intensiv: 137 (+2 siden i går)</li>
<li>I respirator: 90 (uændret)</li>
<li>Antal prøver: 11556903 (+82.795 siden i går)</li>
<li>Raskmeldte: 161.194 (+2451 siden i går)</li>
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}