$re = '/(?:urls = \["(?=\w+(?:","\w+){2,9}"\];)|(?!^)\G",")(\w+)/';
$str = '$js = <<<JS
...
const urls = ["url","url2","url3"];
let url = urls[0];
...
JS;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);