$re = '/^(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z]).{8,}$/m';
$str = 'hello123aA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);