package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\.\*\?\&\$])[\w\s\&]`)
var str = `Foo (.*) bar blla (.*) b*l?a$ && bla bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}