# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^|]*\|){9}[^|]*$"
test_str = ("Susan|Ward |1 |1 |1 |1 |0 |||3250905 \n"
"Allen|Doe|4 |1 |1 |1 |0 ||\n"
"some text\n"
"text\n"
"more text in the same column|3250061 \n"
"Mary|James|4 |1 |1 |1 |0 |||3250061 Albert|Nordling|1 |1 |1 |0 |0 |||900434 \n"
"Henry|Johnson|1 |1 |1 |0 |0 |||900434 \n"
"Tony|Anderson |1 |1 |1 |1 |0 |||3250905 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.