import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([^|\\r\\n]*\\|){0,8}[^|\\r\\n]*$)|(^([^|\\r\\n]*\\|){10,1000}[^|\\r\\n]*$)";
final String string = "Susan|Ward |1 |1 |1 |1 |0 |||3250905 \n"
+ "Allen|Doe|4 |1 |1 |1 |0 ||\n"
+ "some text\n"
+ "text\n"
+ "more text in the same column|3250061 \n"
+ "Mary|James|4 |1 |1 |1 |0 |||3250061 Albert|Nordling|1 |1 |1 |0 |0 |||900434 \n"
+ "Henry|Johnson|1 |1 |1 |0 |0 |||900434 \n"
+ "Tony|Anderson |1 |1 |1 |1 |0 |||3250905 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}