$re = '/\b(?!he\b|it\b)\w+/m';
$str = 'he\'s
it\'s
Mary\'s
Everyone\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);