package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)[\s-\/]\d*`)
var str = `280
240-300
240/300`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}