const regex = /^(?!.*\/products(?:\/|$))(?:.*\/)?(?:child)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\\/products(?:\\\/|$))(?:.*\\\/)?(?:child)$', 'gm')
const str = `https://products.domain.com/products/family/child
https://products.domain.com/family/children
https://products.domain.com/products/family/children
https://products.domain.com/family/child`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);