package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-3][\d]`)
var str = `qwe%
asdf%
zxcvasd%
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}