$re = '/\b(ipsum+)\b(?=.*?\b\1\b)/i';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Curabitur dapibus cursus pellentesque. Fusce accumsan egestas hendrerit. Quisque congue pulvinar dui, eget tristique justo tempor vitae. Phasellus purus ligula, vehicula ut elit ornare, dictum lacinia leo. Aliquam iaculis tincidunt mattis. Ut vel turpis commodo, volutpat enim at, tempus arcu. Vestibulum nec justo vel tortor cursus pharetra. Orci varius natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec pharetra tellus lorem, vitae porttitor purus hendrerit at. Quisque eleifend velit lorem, eu dictum nisl interdum et. Duis laoreet iaculis eros sed aliquam. Nulla eget turpis ipsum. Ut fringilla turpis accumsan lectus consequat lacinia. Nulla nibh lectus, porta ac sem sit amet, tincidunt gravida odio. Cras et est nec sapien accumsan vulputate auctor sed eros. Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Suspendisse consectetur vulputate porttitor. Ut sit amet felis lectus. Quisque malesuada, mi non tempus tincidunt, velit nisi accumsan est, eu cursus nibh erat id urna. Quisque convallis ipsum in leo porta, eu euismod tellus ornare. Aliquam dapibus sagittis lacus, nec malesuada mi consequat quis. Suspendisse tristique purus ac quam semper, at finibus nulla congue. Vestibulum erat massa, imperdiet nec pretium sit amet, tempus vitae diam. Phasellus faucibus purus ut suscipit vehicula. Nam sapien erat, cursus a nunc sit amet, mattis mattis nibh. Nunc sit amet velit sit amet lacus fringilla ornare.
Nunc ullamcorper hendrerit neque vitae hendrerit. Duis accumsan id tortor nec lacinia. Nullam scelerisque mauris at augue vulputate, sit amet ultrices nunc luctus. Integer nec eleifend quam. Pellentesque vitae velit feugiat urna interdum bibendum. Ut nec arcu a diam efficitur viverra. Cras a est accumsan, fringilla nibh vehicula, ornare urna. Phasellus lobortis dignissim sem sit amet vulputate. Suspendisse potenti. Curabitur scelerisque, tortor sit amet vehicula pulvinar, augue turpis sagittis risus, id lobortis orci justo sit amet magna. Suspendisse tincidunt tellus sit amet turpis vestibulum bibendum. Nam molestie scelerisque nisi, dictum ullamcorper est congue quis. Nunc vulputate ullamcorper sollicitudin. Curabitur lobortis ipsum sit amet ipsum aliquam tempor. Vivamus sit amet feugiat neque. Vivamus turpis quam, posuere nec bibendum sed, ultrices vitae mauris.
Mauris vel vehicula purus, sit amet suscipit neque. Aliquam erat volutpat. Donec blandit gravida augue varius ornare. Morbi tempor dapibus sapien vitae eleifend. Vivamus id ligula vel justo porta efficitur. Sed volutpat, odio at aliquam molestie, elit lectus aliquam urna, vel hendrerit purus odio sed arcu. Donec sodales nulla non risus euismod, sed semper augue aliquet. Donec placerat elit nec eleifend malesuada. Pellentesque sed est sem. Donec in elementum enim, sed porttitor diam. Nunc mattis urna porttitor, viverra justo non, tempor metus. Morbi congue erat ligula, at mollis justo malesuada pharetra. Aliquam porta quis metus et semper.
Fusce maximus pellentesque augue vitae rhoncus. Mauris bibendum pellentesque nisi, vel faucibus enim pulvinar quis. Nunc ac enim consectetur, sollicitudin mauris eget, egestas sem. Sed vehicula neque sed metus gravida molestie vel id diam. Vestibulum varius accumsan eros nec pulvinar. Maecenas at feugiat purus. Aliquam vel quam sit amet sem laoreet volutpat. Suspendisse accumsan suscipit erat, eget finibus libero malesuada eget.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);