$re = '/\b[A-Za-zÀ-ȕ]{4,}s\b/m';
$str = 'Hexes pixies major prairies caveman zipfiles oxes fäzes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);