re = /(?P<event_message>An account failed to log on.)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:\s+(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.
*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+Logon Type:\s+(?P<logon_type>.*?)\s+Account For Which Logon Failed:\s+Security ID:\s+(?P<logon_security_id>.*?)\s+Account Name:\s+Administrator\s+Account Domain:\s+(?P<logon_account_domain>.*?)\s+Failure Information:\s+Failure Reason:\s+(?P<failure_reason>.*?)\s+Status:\s+(?P<status>.*?)\s+Sub Status:\s+(?P<sub_status>.*?)\s+Process Information:\s+Caller Process ID:\s+(?P<caller_process_id>.*?)\s+Caller Process Name:\s+(?P<caller_process_name>.*?)\s+Network Information:\s+Workstation Name: (?P<workstation_name>.*?)\s+Source Network Address: (?P<src_addr>.*?)\s+Source Port:\s+(?P<src_port>.*?)\s+Detailed Authentication Information:\s+Logon Process:\s+(?P<logon_process>.*?)\s+Authentication Package:(?P<auth_package>.*?)\s+Transited Services: (?P<trans_serv>.*?)\s+Package Name \(NTLM only\):\s+(?P<package_name>.*?)\s+Key Length:\s+(?P<key_length>.*?)\s+\s+(?P<event_details>.*)/
str = 'An account failed to log on. Subject: Security ID: S-1-0-0 Account Name: - Account Domain: - Logon ID: 0x0 Logon Type: 3 Account For Which Logon Failed: Security ID: S-1-0-0 Account Name: Administrator Account Domain: <acc_domain> Failure Information: Failure Reason: Unknown user name or bad password. Status: 0xC000006D Sub Status: 0xC000006A Process Information: Caller Process ID: 0x0 Caller Process Name: - Network Information: Workstation Name: <ws_name> Source Network Address: - Source Port: - Detailed Authentication Information: Logon Process: NtLmSsp Authentication Package: NTLM Transited Services: - Package Name (NTLM only): - Key Length: 0 This event is generated when a logon request fails. It is generated on the computer where access was attempted. The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe. The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network). The Process Information fields indicate which account and process on the system requested the logon. The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases. The authentication information fields provide detailed information about this specific logon request. - Transited services indicate which intermediate services have participated in this logon request. - Package name indicates which sub-protocol was used among the NTLM protocols. - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end