import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Internal)LogonType=Owner";
final String string = "1. **LogonType=\"Owner\"** MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\"\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"=\" IsValid=\"True\" ObjectState=\"New\"\n\n\n"
+ " 2. 2019-04-01T00:14:59+02:00 Operation=\"\" OperationResult=\"\" LogonType=\"Admin\" ExternalAccess=\"False\" DestFolderId=\"\" DestFolderPathName=\"\" FolderId=\"\" FolderPathName=\"\" ClientInfoString=\"Client=POP3/IMAP4;Protocol=IMAP4\" ClientIPAddress=\"\" ClientMachineName=\"\" ClientProcessName=\"\" ClientVersion=\"\" **InternalLogonType=\"Owner\"** MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"\" IsValid=\"True\" ObjectState=\"New\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}