# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\*LogonType=\"Owner"
test_str = ("1. **LogonType=\"Owner\"** MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\"\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"=\" IsValid=\"True\" ObjectState=\"New\"\n\n\n"
" 2. 2019-04-01T00:14:59+02:00 Operation=\"\" OperationResult=\"\" LogonType=\"Admin\" ExternalAccess=\"False\" DestFolderId=\"\" DestFolderPathName=\"\" FolderId=\"\" FolderPathName=\"\" ClientInfoString=\"Client=POP3/IMAP4;Protocol=IMAP4\" ClientIPAddress=\"\" ClientMachineName=\"\" ClientProcessName=\"\" ClientVersion=\"\" **InternalLogonType=\"Owner\"** MailboxOwnerUPN=\"\" MailboxOwnerSid=\"\" DestMailboxOwnerUPN=\"\" DestMailboxOwnerSid=\"\" DestMailboxGuid=\"\" CrossMailboxOperation=\"\" LogonUserDisplayName=\"\" LogonUserSid=\"\" SourceItems=\"\" SourceFolders=\"\" SourceItemIdsList=\" SourceItemSubjectsList=\"\" SourceItemAttachmentsList=\"\" SourceItemFolderPathNamesList=\"Inbox\" SourceFolderPathNamesList=\"\" ItemId=\"\" ItemSubject=\"\" ItemAttachments=\"\" DirtyProperties=\"\" OriginatingServer=\"\" MailboxGuid=\"\" MailboxResolvedOwnerName=\"\" LastAccessed=\"\" Identity=\"\" IsValid=\"True\" ObjectState=\"New\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.