$re = '/(?<!\>)(\[\s*@?[-_a-zA-Z0-9.$]*%?\s*])(=)(["\'])/';
$str = '<div [ ngStyle ]="{\'max-width.px\': i * 2 + 5}"></div>
<div [ngClass]="[
\'class-one\',
\'class-two\',
\'class-three\'
]"></div>
<div [style.right.%]="val"></div>
<div [@animation.trigger]="val"></div>
<img [attr.aria-label]="val" />
<div [my-property]="val"></div>
<div [my_property]="val"></div>
<div [myProperty$]="val"></div>
/// BELOW SHOULD RETURN NO MATCH
<div [%invalidProperty]="val"></div>
<div [invalidProperty)="val"></div>
<div>[my-property]="val"</div>
<div>
[my-property]="val"
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);