import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\>\\s*)(\\[\\s*@?[-_a-zA-Z0-9.$]*%?\\s*])(=)([\"'])";
final String string = "<div [ ngStyle ]=\"{'max-width.px': i * 2 + 5}\"></div>\n"
+ "<div [ngClass]=\"[\n"
+ " 'class-one',\n"
+ " 'class-two',\n"
+ " 'class-three'\n"
+ "]\"></div>\n"
+ "<div [style.right.%]=\"val\"></div>\n"
+ "<div [@animation.trigger]=\"val\"></div>\n"
+ "<img [attr.aria-label]=\"val\" />\n"
+ "<div [my-property]=\"val\"></div>\n"
+ "<div [my_property]=\"val\"></div>\n"
+ "<div [myProperty$]=\"val\"></div>\n\n\n"
+ "/// BELOW SHOULD RETURN NO MATCH \n\n"
+ "<div [%invalidProperty]=\"val\"></div>\n"
+ "<div [invalidProperty)=\"val\"></div>\n"
+ "<div>[my-property]=\"val\"</div>\n"
+ "<div>\n"
+ " [my-property]=\"val\"\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}