const regex = /\[([^[\]]*SPrice[^[\]]*)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^[\\]]*SPrice[^[\\]]*)]', 'gm')
const str = `I have two square brackets are [Apple = Red, Cool, Sweet] and [Check+SPrice = Cheap, Expensive, Comfortable]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}