package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b%\b`)
var str = `(in %)
%
bla%
bla%bla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}