$re = '/{[^=]*=\K|(?:([^,\r\n]*)(?=,|\s*}))*/m';
$str = '{<c,,4-^ f\' a>8}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);