import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?#skip match process when S exist, or remove optional left most target T, capture left and right part of T.\n"
+ "Use case: if N is not exist, modify/change T to N, or create N. If any create or modify write operated, appending output N to right.\n"
+ "skip exist:)^(?!.*S)(?#\n"
+ "captrue prefix :)^(.*?)(?#\n"
+ "optional target to remove:)(?:T|$)(?#\n"
+ "captrue postfix:)(.*?)$(?#\n"
+ "Test string:\n"
+ "aa\n"
+ "aaT\n"
+ "Tcc\n"
+ "aaTcc\n"
+ "aaTbbTcc\n"
+ "aaS\n"
+ "aaTS\n"
+ "TccS\n"
+ "aaTccS\n"
+ "Saa\n"
+ "SaaT\n"
+ "STcc\n"
+ "SaaTcc\n"
+ "Substitution: $1$2N\n"
+ "Return:\n"
+ "aaN\n"
+ "aaN\n"
+ "ccN\n"
+ "aaccN\n"
+ "aabbTccN\n"
+ "aaS\n"
+ "aaTS\n"
+ "TccS\n"
+ "aaTccS\n"
+ "Saa\n"
+ "SaaT\n"
+ "STcc\n"
+ "SaaTcc)";
final String string = "aa\n"
+ "aaT\n"
+ "Tcc\n"
+ "aaTcc\n"
+ "aaTbbTcc\n"
+ "aaS\n"
+ "aaTS\n"
+ "TccS\n"
+ "aaTccS\n"
+ "Saa\n"
+ "SaaT\n"
+ "STcc\n"
+ "SaaTcc";
final String subst = "$1$2N";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}