using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:Jack\b|(?=\w+(?: +(?!name\b)\w+)* +Jack\b)).*";
string input = @"My name is Jack Brown
I am Jack Brown
Jack Brown is my name
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}