$re = '/^(?!.*\bname\b).*\bJack\b.*/m';
$str = 'My name is Jack Brown
I am Jack Brown
Jack Brown is my name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);