import re
regex = re.compile(r"^(\d{7})\,(?:\n|.)*(\d{2}:\d{2}:\d{2})$", flags=re.MULTILINE)
test_str = ("1158896,someuser,Inner User,Minor,10.6.130.11,2019-09-29 03:01:15,Security Management,Log in to the server,Network Management,Succeeded,User name: someuser,2019-09-29 03:01:15\n"
"1158897,someuser,Inner User,Minor,10.6.130.11,2019-09-29 03:03:16,Security Management,Log out the server,Network Management,Succeeded,\"User name: someuserOnline duration: 0 day(s) 0 hour(s) 2 minute(s) 1 second(s)\",2019-09-29 03:03:16\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")