re = /(?=.{10,})(?=(\w*[A-Z]+\w*[0-9]+\w*)|(\w*[0-9]+\w*[A-Z]+\w*))/
str = 'Написать "проверку пароля", он должен быть не меньше 10 символов, содержать хоть бы одну большую букву и хотя бы одну цифру. Порядок любой то есть, может начинаться с цифры, с буквы (большой или маленькой) и заканчиваться также.
12Camembert
12Cart
Camembert1
Camembert12
Camembert123
Camembert1234
Camembert12345
Camembert2
Camembert2007
Camembert2008
Camembert2k
Camembert3
Camembert4
Camembert4all
Camembert4ever
Camembert4u
Camembert4you
Camembert5
Camembert6
Camembert7
Camembert8
Camembert86
Camembert9
Camemule
CamenRoman07
Camena
Camenae
caveinrock
caveins
caveintherock
caveira
caveira3
caveirac
caveiradac
caveirado3
caveiraecp
caveirahonda
caveiranopc
caveiras
caveiro
caveis
caveitin
cavej
caveji
cavejive
cavejlis
cavejloh
cavejs11
cavejunc
cavejunction
cavejunk
cavek
j902
j90210
j9029j
j902lrk
j903
j903j4af
j904
j90476
j905
j9050066e
j905041
j905380
j9056
j905hnx49
j906
j9061z
j907
j908
j909
j90905
j9092w
j909609c
j90971512
j909ka
j90a
qvivia
qvivian
qviviane
qvivianhsu
qvivianlee
qvivianw
qviviavot
qvivid
qvivien
qvivienne
qvivip
qvivo
qvivr
qvivyan
qviw
qviwaa
qviwbb
qviwge7zp
qviwgezp
qviwlhddh2dc
qviwlhddhdc
qvix
qvixaa
qvixbb
qvixen
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end