package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]{1}[0-9]{9}[02468]{1}$`)
var str = `23888065560`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}