package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)bb\ncc`)
var str = `aaa
bbb
ccc
bbbbb
cccccc
ddd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}