$re = '/\d{4}[-]\d{2}[-]\d{2}/m';
$str = '2.CheckDate variable I want only this date “2017-09-27”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);