import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^allowed.*Count$";
final String string = "allowedHardwareCount\n"
+ "allowedIpAddressCount\n"
+ "allowedReplicationHardwareCount\n"
+ "allowedReplicationIpAddressCount\n"
+ "allowedReplicationSubnetCount\n"
+ "allowedReplicationVirtualGuestCount\n"
+ "allowedSubnetCount\n"
+ "allowedVirtualGuestCount";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}