import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(\\w{1,}\\-\\w{1,}\\.|\\w{1,}\\.|www\\.|)interpolis\\.nl$";
final String string = "https://acc5-www.interpolis.nl\n"
+ "https://interpolis.nl\n"
+ "https://acc-www.interpolis.nl\n"
+ "https://acc5-cm-www.interpolis.nl\n"
+ "https://acc5-taxateurs.interpolis.nl\n"
+ "https://www.interpolis.nl\n"
+ "https://www.mijnsupersecretinterpolis.nl\n"
+ "https://mijnsupersecret.interpolis.nl\n"
+ "https://mijnsupersecret.interpolis.nl.hackers.ru\n"
+ "https://mijnsupersecret.neppedomeinen.interpolis.nl\n"
+ "https://mijnsupersecret.interpolis.nepdomein.nl";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}