import re
regex = re.compile(r"\b(?:\d+)?[24680]\b", flags=re.MULTILINE)
test_str = "1 12 23 34 45 56 67 78 89 90 21 13 24 35 46 57 68 79 80 123 234 345 456 567 678 789 890 2 4 6 8 0"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")